Search found 56 matches

by toddh
06 Sep 2019 14:34
Forum: 4.x Testing
Topic: Shared DB feature?
Replies: 0
Views: 106

Shared DB feature?

Morning, Wondering if there's been any progress on the shared database features? I've been away from the beta for a bit so I have missed some of the posts and updates. I was looking through the most recent change log but didn't see any reference. The 2 instances I've been running as VM's on hyper V ...
by toddh
24 Apr 2019 13:39
Forum: Discussion
Topic: messages with KAM_DRIVENUM 5.0 qurantined
Replies: 3
Views: 695

Re: messages with KAM_DRIVENUM 5.0 qurantined

We are getting a number of valid emails tagged by KAM as spam. The developer is very aggressive. KAM adds weight simply for not having SPF or DKIM records. They also add for having numbers in the subject, and having long URLs in the body(something many emailers do, including Nextdoor). Here is an ex...
by toddh
23 Apr 2019 20:56
Forum: 3.x Feature Requests
Topic: Option to Disable KAM
Replies: 1
Views: 1344

Option to Disable KAM

We are once again dealing with FPs from KAM. I know I can remove the KAM.cf. But then if I understand correct I need to disable SA-Update also. Any my changes may be overwritten by updates. Looking at the eFa report "SpamAssassin Rule Hits" on our system we find that that KAM tags by far more HAM th...
by toddh
14 Mar 2019 02:58
Forum: 4.x Testing
Topic: Default configure options.
Replies: 4
Views: 514

Re: Default configure options.

Answers for our environment 1. Use Ipv6 - No 2. Use recursion - No (having problems with it here) 3. Use efa only inbound - Yes 4. Use greylisting - Yes! 5. Install additional options ( webmin, letsencrypt, etc) I am fine with the option to install these later, not during initial setup 6. Install ad...
by toddh
14 Mar 2019 02:50
Forum: 4.x Testing
Topic: Webmin in EFA4
Replies: 14
Views: 1754

Re: Webmin in EFA4

We do not expose Webmin publicly. It is used only inside the network for system management.

Maybe add a Warning when the package is installed?

Todd
by toddh
14 Mar 2019 02:45
Forum: 4.x Testing
Topic: EFA4 DNS config problem
Replies: 11
Views: 1197

Re: EFA4 DNS config problem

Installed RC3 and DNS Recursion not working. With default setting DNS Recursion Enabled it does not route emails. From mailog Mar 13 21:11:02 SC-EFA4RC3-01 postfix/smtpd[7260]: connect from mail-wm1-f48.google.com[209.85.128.48] Mar 13 21:11:02 SC-EFA4RC3-01 postfix/smtpd[7260]: Anonymous TLS connec...
by toddh
14 Mar 2019 01:47
Forum: 4.x Testing
Topic: How to install EFA4 Beta RC2/RC3 on Hyper-V 2016
Replies: 4
Views: 770

Re: How to install EFA4 Beta RC2 on Hyper-V 2016

Tested and confirmed same procedure works with RC3 on Hyper-V 2016.

Todd
by toddh
04 Mar 2019 16:07
Forum: 4.x Testing
Topic: Webmin in EFA4
Replies: 14
Views: 1754

Re: Webmin in EFA4

I have not used cockpit.

We have webmin accross our Linux boxes because it is a familiar easy to understand interface. That doesn't make it better than anything else...

Except CLI :lol:
by toddh
20 Feb 2019 13:59
Forum: 4.x Testing
Topic: Webmin in EFA4
Replies: 14
Views: 1754

Re: Webmin in EFA4

I certainly dont mind learning new skills. I wish I knew Linux better after working with it for over 10 years. ;) My challenge is the same as for most of us, we have a lot of ground to cover. Various Windows server technologies, different NIX distros and the hardware. I would love to know more about...
by toddh
20 Feb 2019 13:16
Forum: 4.x Testing
Topic: EFA4 DNS config problem
Replies: 11
Views: 1197

Re: EFA4 DNS config problem

No firewall between the EFA boxes and Our DNS. They are on the same subnet.

There is a firewall between the EFA boxes and the External DNS.

We checked logs our DNS servers and no errors for requests being rejected for the EFA4 boxes.
by toddh
18 Feb 2019 23:55
Forum: 4.x Testing
Topic: EFA4 Features list?
Replies: 5
Views: 683

Re: EFA4 Features list?

This is awesome!

Be happy to test if for you. :D
by toddh
18 Feb 2019 23:46
Forum: 4.x Testing
Topic: EFA4 DNS config problem
Replies: 11
Views: 1197

Re: EFA4 DNS config problem

I will turn on Recursion again and post the results.

Recursion was originally on default with no DNS Primary/Secondary servers defined and mails were not passing. But it was generating a different error than with it off as I recall.
by toddh
18 Feb 2019 18:31
Forum: 4.x Testing
Topic: EFA4 Features list?
Replies: 5
Views: 683

Re: EFA4 Features list?

Thanks!

I did not see anything related Clustering or distributed. I did see an item for remote DB support. I may have browsed the list too fast.

Is clustering still on the road map?
by toddh
18 Feb 2019 18:22
Forum: 4.x Testing
Topic: EFA4 DNS config problem
Replies: 11
Views: 1197

Re: EFA4 DNS config problem

With external DNS server 1.1.1.1 /etc/resolv.confg # Generated by NetworkManager search smart-mail.net /etc/unbound/conf.d/forwarders.conf forward-zone: name: "." forward-addr: 1.1.1.1 forward-addr: 4.4.4.4 [admin@EFA4Beta4 ~]$ dig mx google.com ; <<>> DiG 9.9.4-RedHat-9.9.4-73.el7_6 <<>> mx google....
by toddh
15 Feb 2019 17:20
Forum: 4.x Testing
Topic: EFA4 DNS config problem
Replies: 11
Views: 1197

EFA4 DNS config problem

I setup 2 boxes and neither were passing emails. Rejecting connections with: Recipient address rejected: Domain not found The domain was entered into EFA during config. Postfix config and transport files looked fine. I thought maybe a DNS issue? EFA4 during initial config defaulted to DNS Recursion ...
by toddh
15 Feb 2019 14:44
Forum: 4.x Testing
Topic: EFA4 Features list?
Replies: 5
Views: 683

EFA4 Features list?

Is there a list someplace of features and changes that will be included in V4?

Sorry if this is has been covered but I could not find anything posted. ;)

Thanks,

Todd
by toddh
14 Feb 2019 23:57
Forum: 4.x Testing
Topic: Webmin in EFA4
Replies: 14
Views: 1754

Re: Webmin in EFA4

Good idea. I understand not everyone may want or use Webmin, so no sense using the resources. We use Webmin whenever working on EFA. It would take me much longer without File Manager and GUI for editing files copy/paste etc. Also for configuring LDAP, scripts, postfix, mailscanner and so on. We have...
by toddh
14 Feb 2019 22:04
Forum: 4.x Testing
Topic: How to install EFA4 Beta RC2/RC3 on Hyper-V 2016
Replies: 4
Views: 770

How to install EFA4 Beta RC2/RC3 on Hyper-V 2016

Installing EFA 4 Beta on Hyper-V 2016 I posted this in another thread but thought I would make it easier for people to find. Download CentOS 7 Minimal ISO https://www.centos.org/download/ Create a Gen1 VM 2 Cores 1024 Mb RAM Std network connection 20Gb+ HD, the vhdx file will be less than 2Gb after ...
by toddh
14 Feb 2019 18:49
Forum: 4.x Testing
Topic: v4 Beta Login & User problems
Replies: 23
Views: 2128

Re: v4 Beta Login & User problems

Boot to the Centos 7 Min .ISO If you get prompt "boot:" hit enter and that should take you to the next screen. At the startup screen(has aquamarine colored test) hit "Tab" This brings up a string the install uses to configure the install Add below to the end inst.ks=http://dl.efa-project.org/build/4...
by toddh
14 Feb 2019 18:42
Forum: 4.x Testing
Topic: Webmin in EFA4
Replies: 14
Views: 1754

Webmin in EFA4

I am curious. Now that I have the beta up and running I do not see Webmin.

Is that on the roadmap, or something we add on ourselves?

Thanks,

Todd
by toddh
14 Feb 2019 18:35
Forum: 4.x Testing
Topic: v4 Beta Login & User problems
Replies: 23
Views: 2128

Re: v4 Beta Login & User problems

I tried the install several more times on Hyper-V 2016 but met with no success. Today I ran the install on a standard 2016 server and it complete fine. In fact I installed 2 VMs using the kickstarter in Hyper-V 2016 and both have succeeded. My earlier attempts were on a Hyper-V 2016 Cluster with clu...
by toddh
09 Feb 2019 17:46
Forum: 4.x Testing
Topic: v4 Beta Login & User problems
Replies: 23
Views: 2128

Re: v4 Beta Login & User problems

I installed again from the .ISO without the kickstarter - normal Centos install. Install GUI had a hard time detecting the Microsoft Virtual Disk, had to select it manually in the partitioning. Other than that the install looked like it complete normally and I ended up with the same screen after reb...
by toddh
08 Feb 2019 13:32
Forum: 4.x Testing
Topic: v4 Beta Login & User problems
Replies: 23
Views: 2128

Re: v4 Beta Login & User problems

I tried this on Hyper-V 2016 last night from the Kickstarter. Took a while so I let it run over night. When I came in this morning VM was shut down. I ejected .ISO and booted, came to CentOS Linux 7 (Core) Kernel 3.10.0-957.el7.x86_64 on an x86_64 localhost login: I cannot login. I am thinking the i...
by toddh
14 Aug 2018 18:00
Forum: Discussion
Topic: SQLGrey and Senders with Multiple IPs
Replies: 7
Views: 1768

SQLGrey and Senders with Multiple IPs

We are seeing and increase in email delays due to Senders using multiple gateways/IP. In addition some of these senders delay retries for up to 45 minutes or longer. I am sure we can't be the only ones facing this issue where greylisting is delaying email for extended periods, and I am wondering how...
by toddh
14 Aug 2018 17:11
Forum: 3.x Feature Requests
Topic: Shared database, to allow multiple EFA appliances sharing one truth for SQLGrey etc
Replies: 4
Views: 2370

Re: Shared database, to allow multiple EFA appliances sharing one truth for SQLGrey etc

This is already available. We have been doing it for years. All you need is a shared MySQL server and adjust SQLGrey DB settings in /etc/swlgrey/sqlgrey.conf ## Database settings db_type = mysql db_name = sqlgrey db_host = xxx.xxx.xxx.xxx MySQL Server IP db_port = default user = username db_pass = u...