Search found 33 matches

by toddh
14 Aug 2018 18:00
Forum: Discussion
Topic: SQLGrey and Senders with Multiple IPs
Replies: 7
Views: 544

SQLGrey and Senders with Multiple IPs

We are seeing and increase in email delays due to Senders using multiple gateways/IP. In addition some of these senders delay retries for up to 45 minutes or longer. I am sure we can't be the only ones facing this issue where greylisting is delaying email for extended periods, and I am wondering how...
by toddh
14 Aug 2018 17:11
Forum: 3.x Feature Requests
Topic: Shared database, to allow multiple EFA appliances sharing one truth for SQLGrey etc
Replies: 4
Views: 1223

Re: Shared database, to allow multiple EFA appliances sharing one truth for SQLGrey etc

This is already available. We have been doing it for years. All you need is a shared MySQL server and adjust SQLGrey DB settings in /etc/swlgrey/sqlgrey.conf ## Database settings db_type = mysql db_name = sqlgrey db_host = xxx.xxx.xxx.xxx MySQL Server IP db_port = default user = username db_pass = u...
by toddh
07 Mar 2018 00:13
Forum: 3.x How-to
Topic: Need Help - Domains being rejected
Replies: 1
Views: 180

Re: Need Help - Domains being rejected

Got it working.

Turned out in the process of configuring changes for the moved Mail Server I had changed the DNS server as well. Used an internal that probably has split DNS.

Changed it back and all is working now.
by toddh
06 Mar 2018 23:00
Forum: 3.x How-to
Topic: Need Help - Domains being rejected
Replies: 1
Views: 180

Need Help - Domains being rejected

We moved our mail server yesterday and while I was updating some settings in 2 of our EFA boxes I seem to have broken something. We have about 100 domains and 2 out of the 100 are now be rejected. When I send an email from the command line I get "Sender address rejected: Domain not found" One of the...
by toddh
14 Sep 2016 14:10
Forum: 3.x How-to
Topic: Bug after update 3.0.1.1 --> 3.0.1.4
Replies: 6
Views: 1477

Re: Bug after update 3.0.1.1 --> 3.0.1.4

Disregard, thought we were using F-Prot but its actually Sophos on EFA.

Still thanks for all the Great Work!

.
by toddh
14 Sep 2016 02:57
Forum: 3.x How-to
Topic: Bug after update 3.0.1.1 --> 3.0.1.4
Replies: 6
Views: 1477

Re: Bug after update 3.0.1.1 --> 3.0.1.4

Any idea when, or if, F-Prot will be functional in EFA?

We use it as well in conjuction with Clam.

Thanks for all the great work!



.
by toddh
28 Apr 2016 18:25
Forum: 3.x Bugs
Topic: do you know ImageCerberusPLG4 ?
Replies: 8
Views: 4835

Re: do you know ImageCerberusPLG4 ?

Realize this is an old thread but we had this happen today, email block by ImageCerberusPLG4.

It was a .gif that was only a small white rectangle.

Added the exception to local.cf and all is good.

Thanks!


-
by toddh
06 Apr 2016 13:17
Forum: 3.x Bugs
Topic: Update to Version 3.0.0.9 FAILED
Replies: 4
Views: 1478

Re: Update to Version 3.0.0.9 FAILED

Had this problem also and your fix worked.

Thanks!
by toddh
29 Feb 2016 04:44
Forum: 3.x How-to
Topic: How to integrate E.F.A with Active Directory before 3.0.0.5
Replies: 36
Views: 17460

Re: How to integrate E.F.A with Active Directory before 3.0.0.5

Thanks for all the info on this one. Set this up and LDAP was working but still getting an empty file, found we had to add brackets around the proxy address in the filter section. Changed: attrs => "proxyAddresses", to attrs => ["proxyAddresses"], For our filter we are using: filter => "(&(sAMAccoun...
by toddh
04 Feb 2016 17:20
Forum: 3.x How-to
Topic: How to disable kam.cf
Replies: 7
Views: 2644

Re: How to disable kam.cf

Thanks Shawn. I added an exception to the local.cf for the kam_address that was triggering a high number of FPs. We may go further and totally disable the kam.cf. It contains references to Houston high rise building that contain hundreds of business. In it's current state kam.cf is adding weight 2x ...
by toddh
01 Feb 2016 23:12
Forum: 3.x How-to
Topic: How to disable kam.cf
Replies: 7
Views: 2644

How to disable kam.cf

The kam.cf file is causing a lot of FPs and we would like to disable it. I dont see it in the mailscanner or spamassassin config files, but adminitatly I may not be looking in the correct spot. Can someone tell me how to disable this so that it is not run. Also how to remove it so that the file is n...
by toddh
06 Apr 2015 18:47
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

We are running on Hyper-V 2012 R2. I have 2 EFA boxes running and mail is split between them. 1st is on a Hyper-V 2012 R2 Cluster with attached SAN via 40Gb infiniband. 2nd is on SSDs installed in the Hyper-V server. The 2nd EFA on SSDs consistently runs 20 - 25% lower CPU on 15 min average. FYI i h...
by toddh
30 Mar 2015 14:15
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

When I run the command a number of times quickly i get the f0llowig. Not much change in Top. Load was around 2.17, 1.79, 1.58, not a large variance.
EFA MySQL Query1.PNG
EFA MySQL Query1.PNG (41.23 KiB) Viewed 4425 times
by toddh
27 Mar 2015 20:54
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

MySQL query. Ran it a number of times, most responses were like the last 2.
by toddh
27 Mar 2015 20:50
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

Went to look for the pw in /etc/EFA-Conf and found INTERFACE:eth0 But I am using eth1. I get this error when booting. Could this be related EFA eth0 error.PNG I believe this happened after I moved or copied the VM, not sure which. I simply assigned IP info to eth1 when it happened and everything was...
by toddh
27 Mar 2015 18:23
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

Shawn,

Maximum Processing Attempts is set to 0
by toddh
27 Mar 2015 18:12
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

If I remove mail does cpu to to 0. Yes. It drops in the evenings to a load of .3 or so. I also have a 2nd EFA, clone of this VM, that runs as 2nd MX and processed only 400 messages today, load is 0, 0, 0. Do we get a lot of non English? I would say a few but not a lot. Probably a relatively small pe...
by toddh
27 Mar 2015 14:26
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

I think part of my confusion at the high load is that we were previously using a similar box, Postfix, SA, Clam, and it processed the same load on 8 year old hardware with only a fraction of the load. Ran single CPU with 2 or 4 cores and 4gb of ram, averaged around 15% cpu and rarely used 2gb with 2...
by toddh
27 Mar 2015 14:01
Forum: Discussion
Topic: MailScanner Max Children
Replies: 9
Views: 3001

Re: MailScanner Max Children

Thanks the manual is very helpful. I see info about Max Child setting on page 125 but nothing on 141.

Looks like I have some reading to do... :)


when I set Max Children to 10, the web interface in EFA regular reports 16+ during load.


.
by toddh
27 Mar 2015 13:36
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

VM is vhd from EFA. Morning business is starting here so this is normal/light load EFA1 Top1A.PNG Host machine has nothing else significant running. Dell c6100, 2x Xeon L5520( 16 Cores ) 48 Gb ram. The SAN and disk array that the VM sits on runs a number of other VMs so the storage is not idea for t...
by toddh
26 Mar 2015 22:17
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Re: Improving my EFA Performance

Is the VM running out of Memory and swapping - I don't think so. I started with 2 Gb Ram and have been slowly incrementing by 2GB so now I am up to 8 Gb. So far whatever I give it seems to use. However when the slowness occurred several days ago I bumped ram from 6 to 8 Gb and it made no difference....
by toddh
26 Mar 2015 22:01
Forum: Discussion
Topic: MailScanner Max Children
Replies: 9
Views: 3001

Re: MailScanner Max Children

After reading the forum I saw recommendations for running MailScanner Threads per Core anywhere from 1:1 to 4:1. When i tried to add more than 10 from EFA-Configure it of course would not let me so I was just wondering. Then I saw on the MailScanner site they said 5:1 and was really getting confused...
by toddh
26 Mar 2015 21:32
Forum: 3.x How-to
Topic: Searching the forum fails
Replies: 5
Views: 831

Re: Searching the forum fails

Yes I am logged in.

Thanks for the tip on using the Google Search. I have use the Advanced Search but just thought the forum Search would be more effective that Google. I will use Google in the future.
by toddh
26 Mar 2015 14:03
Forum: Discussion
Topic: MailScanner Max Children
Replies: 9
Views: 3001

MailScanner Max Children

I am curious how EFA controls MailScanner Max Children According to the MailScanner site http://www.mailscanner.info/gettingthebest.html MailScanner Leave most things set at defaults. Max Children = 4 x number of CPU cores. Each 5 children require 1GB RAM. But it seems EFA Sets a limit of 10, or the...
by toddh
26 Mar 2015 13:21
Forum: 3.x How-to
Topic: Improving my EFA Performance
Replies: 47
Views: 8943

Improving my EFA Performance

Hello, I am wondering if there is something amiss with my EFA box or this is normal. I have been adjusting hardware and setting trying to improve speed/performance. Not in accuracy but rather how many messages EFA can handle per min/hr. We processed 23588 messages yesterday total. Yesterday morning ...