Search found 27 matches

by kingramon0
07 Feb 2018 19:57
Forum: 3.x Bugs
Topic: No message listing in mailwatch on 3.0.2.6
Replies: 9
Views: 1873

Re: No message listing in mailwatch on 3.0.2.6

I have the same problem But i am not sure How to add the tables in mysql. Could someone help with detailed instructions about how to resolved this? In /etc/EFA-Config there is a line that says MYSQLROOTPWD: followed by some random characters. Copy everything after the colon for the next command. Co...
by kingramon0
31 Jan 2018 15:47
Forum: 3.x Bugs
Topic: SMTPD TLS Cert settings changed during upgrade
Replies: 0
Views: 1083

SMTPD TLS Cert settings changed during upgrade

During the update from 3.0.2.4 to 3.0.2.5 a new self-signed TLS certificate was generated. I didn't catch this until today when one of my users told me they were no longer receiving emails from one of our external services. After troubleshooting I saw that main.cf had been altered to point to a new ...
by kingramon0
29 Jan 2018 03:50
Forum: 3.x Bugs
Topic: Upgrading from 3.0.2.5 to 3.0.2.6 fails inexplicably
Replies: 4
Views: 922

Re: Upgrading from 3.0.2.5 to 3.0.2.6 fails inexplicably

So when I didn't set the NOBACKUP variable to anything, the update completed successfully. Maybe that is buggy, or maybe I should have set it to some value other than 1?
by kingramon0
27 Jan 2018 17:20
Forum: 3.x Bugs
Topic: Upgrading from 3.0.2.5 to 3.0.2.6 fails inexplicably
Replies: 4
Views: 922

Re: Upgrading from 3.0.2.5 to 3.0.2.6 fails inexplicably

It starts taking the backup. But during the update process I set the NOBACKUP=1 variable to skip that and just rely on my VM snapshot.

I can try again without the variable set tonight.
by kingramon0
27 Jan 2018 14:36
Forum: 3.x Bugs
Topic: Upgrading from 3.0.2.5 to 3.0.2.6 fails inexplicably
Replies: 4
Views: 922

Upgrading from 3.0.2.5 to 3.0.2.6 fails inexplicably

Here is the complete log when I run the update: [EFA] Good you are root [EFA] Starting update to EFA-3.0.2.6 [EFA] Good you are root Loaded plugins: fastestmirror, security Setting up Update Process Loading mirror speeds from cached hostfile * EFA: dl7.efa-project.org * base: mirror.umd.edu * epel: ...
by kingramon0
27 Jan 2018 14:23
Forum: 3.x Bugs
Topic: No message listing in mailwatch on 3.0.2.6
Replies: 9
Views: 1873

Re: No message listing in mailwatch on 3.0.2.6

Did you check the update log to see if it had errors? (/var/log/EFA/update-[date]) I had a similar issue. My log showed this during the database upgrade section: MailWatch for MailScanner Database Upgrade to 1.2.7-dev Testing connectivity to the database ................................. OK Updating...
by kingramon0
16 Nov 2017 00:30
Forum: 3.x Bugs
Topic: Web interface not working after auto-update
Replies: 9
Views: 2299

Re: Web interface not working after auto-update

You're welcome. I discovered today after a power outage that the mailscanner service was chkconfig'ed off. It took an embarrassingly long time to figure that out. I thought it was an issue with clamd at first, so I removed it to reinstall and discovered it wasn't in the repos. I had to find an rpm a...
by kingramon0
15 Nov 2017 14:00
Forum: 3.x Bugs
Topic: Web interface not working after auto-update
Replies: 9
Views: 2299

Re: Web interface not working after auto-update

Thanks for taking the time to look over the logs.
by kingramon0
15 Nov 2017 13:58
Forum: 3.x Bugs
Topic: Web interface not working after auto-update
Replies: 9
Views: 2299

Re: Web interface not working after auto-update

I didn't update it in one go. As I said, autoupdate was turned off, but it autoupdated anyway. This is for a friend's small company that is winding down operations, and I basically am just helping them out for free. So, I don't have much time to dedicate to it, so I don't do updates as long as it k...
by kingramon0
10 Nov 2017 17:48
Forum: 3.x Bugs
Topic: Upgrade from 3.0.1.5 to 3.0.2.5 mailwatch
Replies: 3
Views: 1142

Re: Upgrade from 3.0.1.5 to 3.0.2.5 mailwatch

I don't know if you are seeing the same problem that I was, but I solved my issue. If they are similar this might help: viewtopic.php?f=13&t=2808
by kingramon0
10 Nov 2017 17:46
Forum: 3.x Bugs
Topic: Web interface not working after auto-update
Replies: 9
Views: 2299

Re: Web interface not working after auto-update

So I ended up having two issues. First one, as the error above indicates, my conf.php was missing required settings. I created a new conf.php based on conf.php.example. The main thing is to fix the DB_PASS with the MAILWATCHSQLPWD found in /etc/EFA-Config. After that was fixed, I still had issues ge...
by kingramon0
09 Nov 2017 17:56
Forum: 3.x Bugs
Topic: Web interface not working after auto-update
Replies: 9
Views: 2299

Web interface not working after auto-update

Our server auto-updated a few days ago, despite that feature being turned off (it's not the first time this has happened either). Now on 3.0.2.5, we can't get into the web interface. When browsing to /status.php we get this: // Define MailWatch logo name define('MW_LOGO', 'mailwatch-logo.png'); // D...
by kingramon0
01 Sep 2017 15:17
Forum: 3.x Feature Requests
Topic: Automatically include proxyaddresses in global filter for normal users
Replies: 1
Views: 1120

Automatically include proxyaddresses in global filter for normal users

For users that authenticate via LDAP, status and quarantine screens should include that user's proxyaddresses automatically, without having to manually add them to each user's filter list.
by kingramon0
01 Sep 2017 14:05
Forum: Discussion
Topic: How do I allow a user to view messages for shared account
Replies: 1
Views: 694

Re: How do I allow a user to view messages for shared account

Never mind. The Filters option on the User Management page is what does it. I just wasn't sure if there was some query syntax that goes in there and I couldn't find anything that says "just put other email addresses in there". I also didn't realize the user has to log out and back in for the change ...
by kingramon0
01 Sep 2017 13:19
Forum: Discussion
Topic: How do I allow a user to view messages for shared account
Replies: 1
Views: 694

How do I allow a user to view messages for shared account

We have users in our accounting department that have the own individual email accounts, but also have a shared account in Exchange. I know there must be a way to allow them to see the messages destined for the shared account also, but I can't find any documentation on it.

Can anyone give me a hint?
by kingramon0
28 Mar 2017 15:38
Forum: Discussion
Topic: Automatic Upgrade?
Replies: 2
Views: 1099

Re: Automatic Upgrade?

I had it turned off, both at work and at home. I checked and my home installation also upgraded, and both now have auto-update turned on.
by kingramon0
28 Mar 2017 13:56
Forum: Discussion
Topic: Automatic Upgrade?
Replies: 2
Views: 1099

Automatic Upgrade?

Did anyone else see their EFA start an EFA-Version-Upgrade process all on its own? It happened during the middle of our morning here, and I'm the only one that logs into that server. I thought we were being hacked for a second when I saw yum messages that it remove mysql.
by kingramon0
16 Sep 2015 19:32
Forum: 3.x How-to
Topic: Re-send emails in quarantine
Replies: 8
Views: 2680

Re: Re-send emails in quarantine

I found some ways around this that should be good enough, so don't worry about it. Fortunately, it's only a dozen or so users that I need to retrieve stuff for, and I only have two left.

Your SummitStor project is intriguing though. I might need to stalk you on that.
by kingramon0
15 Sep 2015 08:56
Forum: 3.x How-to
Topic: Re-send emails in quarantine
Replies: 8
Views: 2680

Re: Re-send emails in quarantine

I figured out that I need to chmod u+x and remove everything trailling the period in the file name. However, the messages get put in the corrupted queue. My Mailscanner.conf has: # Do you want to quarantine the original *entire* message as well as # just the infected attachments? # This can also be ...
by kingramon0
15 Sep 2015 07:35
Forum: 3.x How-to
Topic: Re-send emails in quarantine
Replies: 8
Views: 2680

Re: Re-send emails in quarantine

The files are just sitting there. Other mail is coming in but it doesn't grab the files I copied. I tried postqueue -f, but nothing. Any ideas?
by kingramon0
15 Sep 2015 06:59
Forum: 3.x How-to
Topic: Re-send emails in quarantine
Replies: 8
Views: 2680

Re: Re-send emails in quarantine

Wow, thanks!

I'm definitely going to need a lot of step 5's, but this will make it so much easier!

Thanks again!
by kingramon0
14 Sep 2015 16:02
Forum: 3.x How-to
Topic: Re-send emails in quarantine
Replies: 8
Views: 2680

Re: Re-send emails in quarantine

So, how would I do it?
by kingramon0
14 Sep 2015 14:36
Forum: 3.x How-to
Topic: Re-send emails in quarantine
Replies: 8
Views: 2680

Re-send emails in quarantine

I might be facing the need to restore our Exchange database from a backup. If that becomes necessary, is it possible to have all the stored messages in EFA after a certain date be redelivered so we don't lose a days worth of emails?
by kingramon0
11 Nov 2014 02:23
Forum: Discussion
Topic: Proxy Addresses and Shared Mailboxes
Replies: 2
Views: 1313

Re: Proxy Addresses and Shared Mailboxes

Well, I have no desire to manually type in filters for 150 users, but knowing that field exists might help me find a place in the code I can modify.

Thanks.