Search found 29 matches

by forhire
02 Jun 2022 06:25
Forum: 4.x Bugs
Topic: HEAD eFa-learn.php
Replies: 5
Views: 325

Re: HEAD eFa-learn.php

freyuh wrote: 09 May 2022 17:08 Thanks for the good idea and the code.
I will test it in my installations the next days.
Did you ever get a chance to play with this? A quick look at my logs suggests it's working well for my users.
by forhire
07 May 2022 02:32
Forum: 4.x Bugs
Topic: HEAD eFa-learn.php
Replies: 5
Views: 325

Re: HEAD eFa-learn.php

I've disabled the .htaccess HEAD filter as I've completed adding a submit button to the submission page. So far this is working. It loads quick and only is delayed once submitted. Sa-learn can be slow sometimes. Basically I added an html form along with flag called $subm. If true then it passes $mid...
by forhire
05 May 2022 17:14
Forum: 4.x Bugs
Topic: HEAD eFa-learn.php
Replies: 5
Views: 325

HEAD eFa-learn.php

I've noticed that some mail clients are querying /mailscanner/eFa-learn.php as HEAD. In reviewing the learned emails it would appear some mail clients are checking every URL in the email using HEAD. This is generating a lot of false sa-learn submissions. sudo grep eFa-learn /var/log/httpd/ssl_access...
by forhire
02 May 2022 03:34
Forum: 4.x Bugs
Topic: Click Here to report links gone
Replies: 26
Views: 4886

Re: Click Here to report links gone

After I Enabled it under option 1) Non Spam Settings I have it appending to ALL domains. Not just the domains appearing in the rules. Mailscanner.conf shows it's using custom(nonspam) as the spam action: Sign Clean Messages = No Non Spam Actions = store deliver header "X-Spam-Status:No" cu...
by forhire
02 May 2022 01:15
Forum: 4.x Bugs
Topic: Click Here to report links gone
Replies: 26
Views: 4886

Re: Click Here to report links gone

Have you edited the inline sig rules? When I added mydomain.com, it inserted rules into these files. sudo grep mydomain.com /etc/MailScanner/rules/* /etc/MailScanner/rules/inline.sig.html.rules:To: *@mydomain.com /etc/MailScanner/reports/en/inline.sig.html /etc/MailScanner/rules/inline.sig.text.rul...
by forhire
01 May 2022 17:11
Forum: 4.x Bugs
Topic: Click Here to report links gone
Replies: 26
Views: 4886

Re: Click Here to report links gone

shawniverson wrote: 12 Mar 2022 17:46 Report link is back in 4.0.4-32:
Shawn, I have enabled inline signature but mailscanner isn't inserting the signature. Any ideas?
by forhire
17 Apr 2022 18:29
Forum: How-to
Topic: Install older version of EFA?
Replies: 2
Views: 844

Re: Install older version of EFA?

shawniverson posted an updated version of mailwatch_milter_relay.php which fixed mtalog_id updates and Relay Information is now working in my version 4.0.4. See this thread:

viewtopic.php?f=19&p=18910#p18907
by forhire
17 Apr 2022 18:22
Forum: 4.x Bugs
Topic: Relay Information missing from message details
Replies: 11
Views: 2297

Re: Relay Information missing from message details

shawniverson, I installed the patched version this morning as it is working great. Thank you!!
by forhire
17 Apr 2022 07:58
Forum: How-to
Topic: Install older version of EFA?
Replies: 2
Views: 844

Re: Install older version of EFA?

Did you ever solve the issue of the mtalod_id table not updating in 4.0.4? I recently updated to 4.0.4 and I have encountered the same issue.

Have you compared /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_postfix_relay.php in 4.0.4 with 4.0.3?
by forhire
17 Apr 2022 05:16
Forum: 4.x Bugs
Topic: Relay Information missing from message details
Replies: 11
Views: 2297

Re: Relay Information missing from message details

The database table mtalog_id is NOT updating. I selected a message from the logs. Grabbed the smtpd_id and the smtp_id and manually inserted them into the mtalog_id table. The Relay Information now appears in the message details for that message. Watching the count on mta_log_id table confirms it is...
by forhire
16 Apr 2022 22:33
Forum: 4.x Bugs
Topic: Relay Information missing from message details
Replies: 11
Views: 2297

Re: Relay Information missing from message details

I ran upgrade.php and postfix_relay is now running.

sudo /usr/bin/php -e /usr/bin/mailwatch/tools/upgrade.php

I'm still not seeing the Relay Information. Now I'm at a real loss. Any ideas?
by forhire
16 Apr 2022 18:32
Forum: 4.x Bugs
Topic: Relay Information missing from message details
Replies: 11
Views: 2297

Re: Relay Information missing from message details

It looks like either I have a missing/broken column in the database or an issue with the field list. Still digging. [user@smtp ~]$ sudo /usr/bin/php -q /usr/bin/mailwatch/tools/Postfix_relay/mailwatch_postfix_relay.php Fatal error: Uncaught mysqli_sql_exception: Unknown column 'to_address' in 'field...
by forhire
16 Apr 2022 18:25
Forum: 4.x Bugs
Topic: Relay Information missing from message details
Replies: 11
Views: 2297

Re: Relay Information missing from message details

I think I found the issue. Not sure why postfix_relay isn't starting. I did managed to get it restart once last night but it promptly died. milter_relay is running. Rebooting the server made no change. Any ideas? [user@smtp ~]$ sudo systemctl status postfix_relay ● postfix_relay.service - Postfix re...
by forhire
14 Apr 2022 00:29
Forum: 4.x Bugs
Topic: Relay Information missing from message details
Replies: 11
Views: 2297

Relay Information missing from message details

After updating eFa I am no longer seeing the Relay Information in the message details. I have confirmed it went missing right when the update was done. Transport is working properly, it's just not capturing the delivery on the details page. Did it possibly get disabled? Any ideas? I have rebooted th...
by forhire
13 Apr 2022 23:40
Forum: 4.x Bugs
Topic: Update dependency mariadb error
Replies: 4
Views: 207

Re: Update dependency mariadb error

Thanks for the URL, it saved my bacon. After swapping mariadb the web gui broke this this error: The following conf.php mandatory entries are missing, check and compare your conf.php with conf.php.example. - DB_PORT I thought the package manager may have archived the config but after reading the thr...
by forhire
13 Apr 2022 19:16
Forum: 4.x Bugs
Topic: Update dependency mariadb error
Replies: 4
Views: 207

Re: Update dependency mariadb error

Thank you! Replacing mariadb did the trick.
by forhire
12 Apr 2022 16:52
Forum: 4.x Bugs
Topic: Update dependency mariadb error
Replies: 4
Views: 207

Update dependency mariadb error

Clearly I'll need to replace my aging Centos7 install of Efa but until I have time I'm seeing this error on update. Failed to check for updates with the following error message: Failed to build transaction: 1:mariadb101u-devel-10.1.41-1.el7.ius.x86_64 requires mariadb101u-libs(x86-64) = 1:10.1.41-1....
by forhire
18 Jun 2021 15:31
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 47
Views: 7948

Re: opendmarc.service failed - kills mailscanner?

bostjanc wrote: 18 Jun 2021 05:58 Forhire do you have the same issue as others? Gateway timeouts?
I havent upgraded yet on our EFAs
I haven't had any issues.
by forhire
18 Jun 2021 05:49
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 47
Views: 7948

Re: opendmarc.service failed - kills mailscanner?

I just ran yum updates and a new version was updated. The epel version has been replaced by an eFa4 rpm. Updated libopendmarc-1.4.1-1.el7.x86_64 @epel Update 1.4.1.1-1.eFa.1.el7.x86_64 @eFa4 Updated opendmarc-1.4.1-1.el7.x86_64 @epel Update 1.4.1.1-1.eFa.1.el7.x86_64 @eFa4
by forhire
15 Jun 2021 02:17
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 47
Views: 7948

Re: opendmarc.service failed - kills mailscanner?

I attempted to build an updated RPM with the new patch but I must not have all my dependencies sorted as I'm seeing a LOT of errors during the build. Has anyone had success with the patch?

https://patch-diff.githubusercontent.co ... /178.patch
by forhire
14 Jun 2021 14:31
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 47
Views: 7948

Re: opendmarc.service failed - kills mailscanner?

Unfortunately I haven't seen it since. I've been up for 48 hours.

This is being discussed over on opendmarc with a source patch but it hasn't been put in the rpm.
https://github.com/trusteddomainproject ... issues/179
by forhire
12 Jun 2021 20:15
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 47
Views: 7948

Re: opendmarc.service failed - kills mailscanner?

Just prior to opendmarc entering a failed state I'm seeing this error: Jun 11 23:13:21 smtp postfix/cleanup[17792]: warning: milter inet:localhost:8893: can't read SMFIC_BODYEOB reply packet header: Success And they have all been related to a spam email originating from: client=os3-362-14218.vs.saku...
by forhire
12 Jun 2021 14:57
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 47
Views: 7948

Re: opendmarc.service failed - kills mailscanner?

No joy. It crashed overnight. The issue persists.
by forhire
12 Jun 2021 02:52
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 47
Views: 7948

Re: opendmarc.service failed - kills mailscanner?

I just ran yum and installed a pile of updates. I was fully updated yesterday when I checked. This update includes kernel-3.10.0-1160.31.1.el7.x86_64 update which I suspect may solve problem. We'll see. ;)
by forhire
11 Jun 2021 16:33
Forum: 4.x Bugs
Topic: opendmarc.service failed - kills mailscanner?
Replies: 47
Views: 7948

Re: opendmarc.service failed - kills mailscanner?

I enabled auto restart in /etc/opendmarc.conf. I'll check the logs later today and see if it restarts as it should.

AutoRestart true
AutoRestartCount 0
AutoRestartRate 10/1h

I've been monitoring my logs using this:
sudo grep opend /var/log/messages | grep 'failed state'