Search found 49 matches

by Woger
06 Nov 2017 17:19
Forum: Discussion
Topic: SPF not working
Replies: 12
Views: 944

Re: SPF not working

Ok, after changing my primary nameserver on the EFA server to another nameserver it started working again: spamassassin -D < /var/spool/MailScanner/quarantine/20171106/nonspam/527E9C00CF.AE751 2>&1 | grep -i spf Nov 6 18:18:37.451 [17813] dbg: spf: checking to see if the message has a Received-SPF h...
by Woger
06 Nov 2017 17:11
Forum: Discussion
Topic: SPF not working
Replies: 12
Views: 944

Re: SPF not working

Ok, I tried it on a existing nonspam email: spamassassin -D < /var/spool/MailScanner/quarantine/20171106/nonspam/527E9C00CF.AE751 2>&1 | grep -i spf and got this: Nov 6 18:06:40.550 [14269] dbg: spf: checking to see if the message has a Received-SPF header that we can use Nov 6 18:06:40.574 [14269] ...
by Woger
06 Nov 2017 16:49
Forum: Discussion
Topic: SPF not working
Replies: 12
Views: 944

Re: SPF not working

I tried adding the above settings to local.cf but when I receive an email from gmail I got this info: 0.01 T_SPF_HELO_TEMPERROR SPF: test of HELO record failed (temperror) 0.01 T_SPF_TEMPERROR SPF: test of record failed (temperror) I get this info on every email I receive. Seems SPF is not working f...
by Woger
01 Nov 2017 08:31
Forum: 3.x Feature Requests
Topic: Make whitelist/blacklist active immediately
Replies: 2
Views: 128

Make whitelist/blacklist active immediately

I have sometimes spam boms coming from just one emailaddress. I block these by just adding the emailaddress to the blacklist. However, the blacklist only refreshes with every auto reload of mailscanner which is (I think) 10 to 20 minutes or so. What happens is that I add an emailaddress to the black...
by Woger
01 Nov 2017 08:22
Forum: 3.x Feature Requests
Topic: A fallback mailserver image
Replies: 9
Views: 285

Re: A fallback mailserver image

Gr8wonder,
Sounds doable. My second server will be on another network. But you say, this is covered by EFA4? As you can see by my slow responses, I don't have much time at the moment, so just wait for EFA4 is the best solution now. Great work (again) by the developers :clap:
by Woger
09 Oct 2017 15:11
Forum: 3.x Feature Requests
Topic: A fallback mailserver image
Replies: 9
Views: 285

Re: A fallback mailserver image

I have a dedicated mail server behind the 2 mailgateways and in front of the 2 mailgateways there is another mailserver in another continent which just forwards mail to the 2 mailgateways. However, I probably have to wait for EFA4 then. In the meantime I will try to replace the secondary by a EFA se...
by Woger
09 Oct 2017 08:55
Forum: 3.x How-to
Topic: Using EFA as MX1 and MX2
Replies: 16
Views: 524

Re: Using EFA as MX1 and MX2

disciple wrote:
04 Oct 2017 10:44
Hi Woger, how would you configure that? Round robin and one MX record?
Something like this:

mailserver.domain.com. A IN 1.2.3.4
mailserver.domain.com. A IN 1.2.3.5

domain.com. 10 MX mailserver.domain.com.

I think that should work, but haven't tried it ;)
by Woger
09 Oct 2017 08:49
Forum: 3.x Feature Requests
Topic: A fallback mailserver image
Replies: 9
Views: 285

Re: A fallback mailserver image

Sorry pdwalker, I was a bit busy last week. Yes, I use the secondary server as a backup server for the first one. The first one has a MX record with 10 and the second with 100 so the first one should handle (almost) all mail. The second one is mostly as a backup when the first goes down to keep the ...
by Woger
29 Sep 2017 11:37
Forum: 3.x How-to
Topic: Using EFA as MX1 and MX2
Replies: 16
Views: 524

Re: Using EFA as MX1 and MX2

For load balancing I would use round-robin and just one mx record.
But I use also a primary and a secondary mailserver. The adds an extra point to the spamassassin score just because it's the secondary and mostly used by spammers.
by Woger
29 Sep 2017 10:27
Forum: 3.x Feature Requests
Topic: A fallback mailserver image
Replies: 9
Views: 285

A fallback mailserver image

Hi, I am using an EFA server for checking mail for a few hundred domains. It works great and I am very happy with it. I use an older server as fallback server. I want to replace the old server with also an EFA server but the system requirements for EFA force me to get a server which is way too heavy...
by Woger
29 Aug 2017 20:58
Forum: Discussion
Topic: spamassassin autolearn always no
Replies: 10
Views: 622

Re: spamassassin autolearn always no

I have that too, and I just saw an autlearn yes (no spam) , so it seems to be working. But I can't find a single spam message where the autolearn also said yes :(
by Woger
29 Aug 2017 13:53
Forum: Discussion
Topic: spamassassin autolearn always no
Replies: 10
Views: 622

spamassassin autolearn always no

My bayes database is scoring but every spam email I receive has got "spamassassin autolearn: no". I do quite some manual learning but it seems that autolearn is not working. I have add bayes_auto_learn_threshold_spam 9.0 to /etc/MailScanner/spamassassin.conf and restarted mailscanner, but still no a...
by Woger
24 Aug 2017 17:22
Forum: Discussion
Topic: Different SPF score for one domain only
Replies: 0
Views: 140

Different SPF score for one domain only

Hi, I have a lot of domains on the EFA server. One of the domain owners want their SPF fail to really be blocked. I tried writing a rule where the domainname is taken from the header together with SPF_FAIL: header __DOMAIN1 From =~ /domain\.com/ meta DOMAINSPF (__DOMAIN1 && SPF_FAIL) describe DOMAIN...
by Woger
24 Aug 2017 16:56
Forum: Discussion
Topic: SPF not working
Replies: 12
Views: 944

Re: SPF not working

To answer my own question. Yes it does :)

Thanks Thewomble
by Woger
24 Aug 2017 16:45
Forum: Discussion
Topic: SPF not working
Replies: 12
Views: 944

Re: SPF not working

Yep, That was it. I changed the domainname for its IP address but forgot to change the a: to ip4: :? However the score for SPF fail is 0. Can I just put : score SPF_FAIL 0 0 0 3.50 score SPF_SOFTFAIL 0 0 0 1.50 score SPF_HELO_FAIL 0 0 0 1.00 score SPF_HELO_SOFTFAIL 0 0 0 0.50 In local.cf to overrule...
by Woger
24 Aug 2017 15:38
Forum: Discussion
Topic: SPF not working
Replies: 12
Views: 944

SPF not working

Hi, I noticed that all my incoming mails for all domains (about 100) have the same SPF score by spamassassin: 0.01 T_SPF_HELO_PERMERROR SPF: test of HELO record failed (permerror) 0.01 T_SPF_PERMERROR SPF: test of record failed (permerror) I have setup a domain with a SPF record for fail but still g...
by Woger
21 Jun 2017 16:34
Forum: 3.x How-to
Topic: Can't login anymore
Replies: 2
Views: 218

Re: Can't login anymore

hmmm.. same problem is here:
viewtopic.php?t=2034

Also using chrome and also working in other browsers. Very strange.
by Woger
21 Jun 2017 15:22
Forum: 3.x How-to
Topic: Can't login anymore
Replies: 2
Views: 218

Re: Can't login anymore

Just found out that when I use the IP address of the server instead of the domainname I can log in. So it has something to do with the DNS.
by Woger
21 Jun 2017 14:47
Forum: 3.x How-to
Topic: Can't login anymore
Replies: 2
Views: 218

Can't login anymore

First, I upgraded yesterday to the latest version (.1 to .3). This morning I found out that the local dns wasn't working anymore since 2 days and no mails where filtered/accepted :( . after changing the DNS servers in /etc/resolv.conf the mail started flowing again. Now, about 5 hours later I sudden...
by Woger
19 Apr 2017 07:45
Forum: 3.x How-to
Topic: mail-DAEMON error overloading efa server
Replies: 13
Views: 938

Re: mail-DAEMON error overloading efa server

are the mails sent to non existing emailaddresses? Then you can use recipient address verification in Postfix. Postfix will first check if the recipient really exists by doing a fake login on the recipient mailserver. If it exists it takes the mail, if not, it refuses the mail. Works also with a loc...
by Woger
19 Apr 2017 06:40
Forum: Discussion
Topic: honeypot
Replies: 9
Views: 1843

Re: honeypot

Putting the spam mails directly in spamassassin is offcourse the best option. It will be learned as spam as soon as it arrives. Wil work great when you get a spam bomb. But how do you want to create spamassassin rules? You still have to do that by hand or use very low scores to be sure it won't hit ...
by Woger
12 Apr 2017 12:56
Forum: Discussion
Topic: blank screen on viewmail.php
Replies: 1
Views: 199

Re: blank screen on viewmail.php

Ok,

This solution did the trick. Setting Quarantine Whole Messages As Queue Files = no in MailScanner.conf.
by Woger
12 Apr 2017 11:56
Forum: 3.x Bugs
Topic: Release e-mail
Replies: 13
Views: 1099

Re: Release e-mail

On mailwatch site it says:
Changelog

Fixes

Regression in SA Learning and Releasing not working in detail page

Fir latest version (1.2.2) but EFA is using 1.2.3dev . Is it possible that fixes from the stable version are not included in the development version?
Why is EFA using a dev version btw.?
by Woger
12 Apr 2017 11:05
Forum: Discussion
Topic: blank screen on viewmail.php
Replies: 1
Views: 199

blank screen on viewmail.php

I am getting blank screens when trying to view a message. I had a problem getting mime errors 11 and 12 on the previous version of EFA and found a post to repair that. After that I got blank screens but That was a bug in mailwatch and repaired in the latest version. So I decided to just upgrade to t...